Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 21, 2025 - 20:00 CEST
Scheduled
Exceptional maintenance from June 21, 2025 at 20:00 (UTC+2) to June 22, 2025 at 06:30 (UTC+2) Monday 16 June 2025 12:00 PM UTC+00 Exceptional maintenance from June 21, 2025 at 20:00 (UTC+2) to June 22, 2025 at 06:30 (UTC+2)
In order to improve our services, we have planned from June 21, 2025 at 20:00 (UTC+2) to June 22, 2025 at 06:30 (UTC+2) an exceptional maintenance on our Crédit Mutuel Open Banking API. Thank you for your understanding.
Posted Jun 17, 2025 - 11:37 CEST
This scheduled maintenance affected: France (Crédit Mutuel).